Nooooooo! My Duo-R died!

Talk about all aspect of Japanese games.

Moderator: Gaijin Punch

User avatar
CIT Seven Force
Borderline recluse
Borderline recluse
Posts: 1041
Joined: Fri Jun 10, 2005 8:51 pm
Location: Berlin, Germany

Nooooooo! My Duo-R died!

Postby CIT Seven Force » Thu Jul 14, 2005 4:49 pm

Got a couple of new HuCards today and wanted to pop them in, but when I flicked that powerswitch... ...nothing... absolutely nothing... No picture, no sound, no LED lighting up. Once I got over the shock I went through all the steps, checking the cords, plugging the AC adapter in upside down, etc, etc, but all to no avail. I've heard of people suddenly having this problem (not having dropped the system or anything) but I couldn't find anything about how to fix it. I'm assuming it's the fuse inside the Duo-R. Does anybody know of a way to fix this? :( :( :(

User avatar
Gaijin Punch
Supreme Leader
Supreme Leader
Posts: 8050
Joined: Tue Apr 06, 2004 9:02 am
Location: in da house

Postby Gaijin Punch » Thu Jul 14, 2005 6:22 pm

No idea w/o looking. I had a similar problem w/ my Duo-RX recently. I eventually sold it very cheap.... the person turned it on the first time and it worked. :(
Rade wrote:Finally received a reply by posting in a thread at that Gaijin forum:

User avatar
CIT Seven Force
Borderline recluse
Borderline recluse
Posts: 1041
Joined: Fri Jun 10, 2005 8:51 pm
Location: Berlin, Germany

Postby CIT Seven Force » Thu Jul 14, 2005 7:55 pm

Damn. Sorry to hear about that. It just occured to me that it might only be AC adapter that's busted. I'll borrow my friend's AC adapter this weekend, maybe it'll work. Unfortunately PCE power cords aren't that easy to find either... :(

Bighab
Past The Newbie Stage
Past The Newbie Stage
Posts: 194
Joined: Sat Apr 10, 2004 7:53 pm
Location: Kitchener,Ontario,Canada

Postby Bighab » Thu Jul 14, 2005 8:11 pm

Gaijin Punch wrote: I eventually sold it very cheap.... the person turned it on the first time and it worked. :(
Dam that sucks. Did he offer to send it back to you? :o

User avatar
fpbrush
Exchange Student
Exchange Student
Posts: 31
Joined: Fri Apr 30, 2004 8:59 pm
Location: USA

Postby fpbrush » Fri Jul 15, 2005 1:48 am

Sorry to hear about this man.. It's always a scare when a system like this goes on the blink. If trying a new AC adaptor doesn't work, you may want to contact DLite of Pcenginefx.com and neo-geo.com forums. He seems to know quite a bit about PC engine Duo systems and possible repairs. Good luck!

User avatar
Gaijin Punch
Supreme Leader
Supreme Leader
Posts: 8050
Joined: Tue Apr 06, 2004 9:02 am
Location: in da house

Postby Gaijin Punch » Fri Jul 15, 2005 4:32 am

Dam that sucks. Did he offer to send it back to you? :o
Nope...that's the way it goes. I wasn't too burned about it anyway... shit happens. :)
Rade wrote:Finally received a reply by posting in a thread at that Gaijin forum:

PCEngine_Hunter
Past The Newbie Stage
Past The Newbie Stage
Posts: 158
Joined: Sun Apr 24, 2005 9:19 am

Postby PCEngine_Hunter » Sat Jul 16, 2005 3:51 am

Aww, that really sucks. I am always worried about my older systems dying on me. I am kinda worried about my Duo-RX at the moment because the last time I used it a few weeks ago, when I looked at the back-up data screen, after 2 or 3 seconds the screen went all screwy and I had to turn it off. It was OK when I used it again but still, I am worried about it.... Hope that other AC adaptor works out for ya.


Return to “Japanese Video Games”

Who is online

Users browsing this forum: No registered users and 9 guests

cron